{"action":"Upgrade glib2.0 to 2.20.0-1 or later.","affected":[{"fixed":"2.20.0-1","introduced":"0"}],"component":"glib2.0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.20.0-1"],"id":"tcs_01M5N93SFQRCX57531FTBWAV8E","modified_at":"2026-10-23T17:47:49.525509172Z","published_at":"2009-03-14T18:30:00.343Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-4316","https://security-tracker.debian.org/tracker/CVE-2008-4316"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-4316","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-4316"}],"summary":"Multiple integer overflows in glib/gbase64.c in GLib before 2.20 allow context-dependent attackers to execute arbitrary code via a long string that is converted either (1) from or (2) to a base64 repr"}