{"action":"Upgrade org.xwiki.contrib.oidc:oidc-authenticator to 1.29.1 or later.","affected":[{"fixed":"1.29.1","introduced":"0"}],"component":"org.xwiki.contrib.oidc:oidc-authenticator","cve_ids":["CVE-2022-39387"],"ecosystem":"Maven","epss":0.01191,"exploited":false,"fixed_versions":["1.29.1"],"ghsa_id":"GHSA-m7gv-v8xx-v47w","id":"tcs_01M5N94MMVNYGHNWZDCHZ1PCW0","modified_at":"2023-11-08T04:10:20.653987Z","published_at":"2022-11-04T18:58:46Z","references":["https://osv.dev/vulnerability/GHSA-m7gv-v8xx-v47w","https://github.com/xwiki-contrib/oidc/security/advisories/GHSA-m7gv-v8xx-v47w","https://nvd.nist.gov/vuln/detail/CVE-2022-39387","https://github.com/xwiki-contrib/oidc/commit/0247af1417925b9734ab106ad7cd934ee870ac89","https://github.com/xwiki-contrib/oidc","https://jira.xwiki.org/browse/OIDC-118"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-m7gv-v8xx-v47w","url":"https://osv.dev/vulnerability/GHSA-m7gv-v8xx-v47w"}],"summary":"XWiki OIDC Authenticator vulnerable to bypassing OpenID login by providing a custom provider"}