{"action":"Upgrade io.netty:netty-codec-compression to 4.2.13.Final or later.","affected":[{"fixed":"4.2.13.Final","introduced":"0"}],"component":"io.netty:netty-codec-compression","cve_ids":["CVE-2026-42583"],"ecosystem":"Maven","epss":0.00461,"exploited":false,"fixed_versions":["4.2.13.Final"],"ghsa_id":"GHSA-mj4r-2hfc-f8p6","id":"tcs_01M5N957TPZ4CEWFZQCHJERTWV","modified_at":"2026-09-10T03:51:06.526589004Z","published_at":"2026-05-07T00:20:35Z","references":["https://osv.dev/vulnerability/GHSA-mj4r-2hfc-f8p6","https://github.com/netty/netty/security/advisories/GHSA-mj4r-2hfc-f8p6","https://nvd.nist.gov/vuln/detail/CVE-2026-42583","https://github.com/netty/netty"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-mj4r-2hfc-f8p6","url":"https://osv.dev/vulnerability/GHSA-mj4r-2hfc-f8p6"}],"summary":"Netty Lz4FrameDecoder is vulnerable to resource exhaustion"}