{"action":"Upgrade org.apache.orc:orc to 1.4.4 or later.","affected":[{"fixed":"1.4.4","introduced":"1.0.0"}],"component":"org.apache.orc:orc","cve_ids":["CVE-2018-8015"],"ecosystem":"Maven","epss":0.03233,"exploited":false,"fixed_versions":["1.4.4"],"ghsa_id":"GHSA-mqmp-4mcp-vg8v","id":"tcs_01M5N95KB27JYX5VDARJ3KG7TR","modified_at":"2026-09-10T03:49:23.912934856Z","published_at":"2022-05-13T01:20:37Z","references":["https://osv.dev/vulnerability/GHSA-mqmp-4mcp-vg8v","https://nvd.nist.gov/vuln/detail/CVE-2018-8015","https://github.com/apache/orc/pull/266","https://github.com/apache/orc/commit/d5018d309a8adc6b8e0567cb692a17371d16e108","https://github.com/apache/orc","https://github.com/apache/orc/blob/9cf9d26a20ac4d43911d7967ecaef8ef26b60594/site/security/CVE-2018-8015.md","https://github.com/apache/orc/commits/rel/release-1.4.4","https://orc.apache.org/security/CVE-2018-8015"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-mqmp-4mcp-vg8v","url":"https://osv.dev/vulnerability/GHSA-mqmp-4mcp-vg8v"}],"summary":"Apache ORC vulnerable to Uncontrolled Recursion"}