{"action":"Upgrade xrdp to 0.4.0~dfsg-9 or later.","affected":[{"fixed":"0.4.0~dfsg-9","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.4.0~dfsg-9"],"id":"tcs_01M5N964KPQ2ASWFZ4AAT5DZF0","modified_at":"2026-10-23T17:47:27.296511307Z","published_at":"2009-01-15T17:30:00.280Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-5902","https://security-tracker.debian.org/tracker/CVE-2008-5902"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-5902#Debian:14/xrdp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-5902"}],"summary":"Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request."}