{"action":"Upgrade xrdp to 0.4.0~dfsg-9 or later.","affected":[{"fixed":"0.4.0~dfsg-9","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.4.0~dfsg-9"],"id":"tcs_01M5N964RFP3PVSMNS88F2ZBF8","modified_at":"2026-10-23T17:47:46.725586071Z","published_at":"2009-01-15T17:30:00.313Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-5903","https://security-tracker.debian.org/tracker/CVE-2008-5903"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-5903","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-5903"}],"summary":"Array index error in the xrdp_bitmap_def_proc function in xrdp/funcs.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via vectors that manipulate the value of the edit_pos"}