{"action":"Upgrade org.jenkins-ci.plugins:mask-passwords to 3.1 or later.","affected":[{"fixed":"3.1","introduced":"0"}],"component":"org.jenkins-ci.plugins:mask-passwords","cve_ids":["CVE-2022-29043"],"ecosystem":"Maven","epss":0.0083,"exploited":false,"fixed_versions":["3.1"],"ghsa_id":"GHSA-pjm3-f4vh-3h3h","id":"tcs_01M5N97NF3SXTQTD7DBZRGY5NE","modified_at":"2024-02-16T08:23:03.745871Z","published_at":"2022-04-13T00:00:17Z","references":["https://osv.dev/vulnerability/GHSA-pjm3-f4vh-3h3h","https://nvd.nist.gov/vuln/detail/CVE-2022-29043","https://github.com/jenkinsci/mask-passwords-plugin/commit/55022b3f1935dc005c4075161c176b29bce7b849","https://github.com/jenkinsci/mask-passwords-plugin","https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-pjm3-f4vh-3h3h","url":"https://osv.dev/vulnerability/GHSA-pjm3-f4vh-3h3h"}],"summary":"Stored Cross-site Scripting in Jenkins Mask Passwords Plugin"}