{"action":"Upgrade org.apache.kylin:kylin-server-base to 4.0.2 or later.","affected":[{"fixed":"4.0.2","introduced":"0"}],"component":"org.apache.kylin:kylin-server-base","cve_ids":["CVE-2022-24697"],"ecosystem":"Maven","epss":0.84777,"exploited":false,"fixed_versions":["4.0.2"],"ghsa_id":"GHSA-ppxx-m926-g569","id":"tcs_01M5N97VAYSWY116VVDN8487PG","modified_at":"2025-05-16T22:37:55.472859Z","published_at":"2023-07-06T19:24:01Z","references":["https://osv.dev/vulnerability/GHSA-ppxx-m926-g569","https://nvd.nist.gov/vuln/detail/CVE-2022-24697","https://github.com/apache/kylin/pull/1811","https://github.com/apache/kylin","https://lists.apache.org/thread/07mnn9c7o314wrhrwjr10w9j5s82voj4","http://www.openwall.com/lists/oss-security/2022/12/30/1"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-ppxx-m926-g569#Maven/org.apache.kylin:kylin-server-base","url":"https://osv.dev/vulnerability/GHSA-ppxx-m926-g569"}],"summary":"Apache Kylin vulnerable to remote code execution"}