{"action":"Upgrade org.jenkins-ci.plugins:nodelabelparameter to 1.10.3.1 or later.","affected":[{"fixed":"1.10.3.1","introduced":"0"}],"component":"org.jenkins-ci.plugins:nodelabelparameter","cve_ids":["CVE-2022-29044"],"ecosystem":"Maven","epss":0.00663,"exploited":false,"fixed_versions":["1.10.3.1"],"ghsa_id":"GHSA-pv7p-c7cp-vrh3","id":"tcs_01M5N981RS48T7FKVYKS9DPFNB","modified_at":"2024-02-16T08:20:59.020103Z","published_at":"2022-04-13T00:00:16Z","references":["https://osv.dev/vulnerability/GHSA-pv7p-c7cp-vrh3","https://nvd.nist.gov/vuln/detail/CVE-2022-29044","https://github.com/jenkinsci/nodelabelparameter-plugin/commit/b8a95cbf678e18dd1f936fd38f23b8cb0695ded7","https://github.com/jenkinsci/nodelabelparameter-plugin","https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-pv7p-c7cp-vrh3","url":"https://osv.dev/vulnerability/GHSA-pv7p-c7cp-vrh3"}],"summary":"Stored Cross-site Scripting in Jenkins Node and Label parameter Plugin"}