{"action":"Upgrade cyrus-sasl2 to 2.1.23.dfsg1-1 or later.","affected":[{"fixed":"2.1.23.dfsg1-1","introduced":"0"}],"component":"cyrus-sasl2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.1.23.dfsg1-1"],"id":"tcs_01M5N9832RHX8XS3QA33V8VE16","modified_at":"2026-10-23T17:47:24.172877534Z","published_at":"2009-05-15T15:30:00.187Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-0688","https://security-tracker.debian.org/tracker/CVE-2009-0688"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-0688#Debian:13/cyrus-sasl2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-0688"}],"summary":"Multiple buffer overflows in the CMU Cyrus SASL library before 2.1.23 might allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via strings that are used"}