{"action":"Upgrade mapserver to 5.2.2-1 or later.","affected":[{"fixed":"5.2.2-1","introduced":"0"}],"component":"mapserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.2.2-1"],"id":"tcs_01M5N98FV81XCD2XSXPY156FBB","modified_at":"2026-10-23T17:47:33.212396880Z","published_at":"2009-03-31T18:24:45.907Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-0842","https://security-tracker.debian.org/tracker/CVE-2009-0842"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-0842","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-0842"}],"summary":"mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2 allows remote attackers to read arbitrary invalid .map files via a full pathname in the map parameter, which triggers the display of partial"}