{"action":"Upgrade mapserver to 5.2.2-1 or later.","affected":[{"fixed":"5.2.2-1","introduced":"0"}],"component":"mapserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.2.2-1"],"id":"tcs_01M5N98VR5M1BE5G65NJ0QB1EV","modified_at":"2026-10-23T17:47:37.233984559Z","published_at":"2009-03-31T18:24:45.967Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-1176","https://security-tracker.debian.org/tracker/CVE-2009-1176"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-1176#Debian:13/mapserver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-1176"}],"summary":"mapserv.c in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2 does not ensure that the string holding the id parameter ends in a '\\0' character, which allows remote attackers to conduct buf"}