{"action":"Upgrade mapserver to 5.2.2-1 or later.","affected":[{"fixed":"5.2.2-1","introduced":"0"}],"component":"mapserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.2.2-1"],"id":"tcs_01M5N98W114J4YN61VDW0TXCP4","modified_at":"2026-10-23T17:47:32.319524856Z","published_at":"2009-03-31T18:24:45.983Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-1177","https://security-tracker.debian.org/tracker/CVE-2009-1177"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-1177","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-1177"}],"summary":"Multiple stack-based buffer overflows in maptemplate.c in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2 have unknown impact and remote attack vectors."}