{"action":"Upgrade io.swagger:swagger-parser to 1.0.31 or later.","affected":[{"fixed":"1.0.31","introduced":"0"}],"component":"io.swagger:swagger-parser","cve_ids":["CVE-2017-1000208"],"ecosystem":"Maven","epss":0.01705,"exploited":false,"fixed_versions":["1.0.31"],"ghsa_id":"GHSA-q7pf-qr96-2vq5","id":"tcs_01M5N990V0AZ5Z2VK7P841B5H3","modified_at":"2023-11-08T03:58:44.108818Z","published_at":"2018-10-19T16:46:41Z","references":["https://osv.dev/vulnerability/GHSA-q7pf-qr96-2vq5","https://nvd.nist.gov/vuln/detail/CVE-2017-1000208","https://github.com/advisories/GHSA-q7pf-qr96-2vq5","https://github.com/swagger-api/swagger-parser","https://github.com/swagger-api/swagger-parser/releases/tag/v1.0.31","https://lgtm.com/blog/swagger_snakeyaml_CVE-2017-1000207_CVE-2017-1000208"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-q7pf-qr96-2vq5#Maven/io.swagger:swagger-parser","url":"https://osv.dev/vulnerability/GHSA-q7pf-qr96-2vq5"}],"summary":"Deserialization of Untrusted Data in swagger-parser"}