{"action":"Upgrade org.jenkins-ci.plugins:htmlpublisher to 1.21 or later.","affected":[{"fixed":"1.21","introduced":"0"}],"component":"org.jenkins-ci.plugins:htmlpublisher","cve_ids":["CVE-2019-10432"],"ecosystem":"Maven","epss":0.01177,"exploited":false,"fixed_versions":["1.21"],"ghsa_id":"GHSA-q829-hrmc-84c8","id":"tcs_01M5N991CXBG9VFDRSDYTWM822","modified_at":"2024-02-16T08:12:15.153682Z","published_at":"2022-05-24T16:57:28Z","references":["https://osv.dev/vulnerability/GHSA-q829-hrmc-84c8","https://nvd.nist.gov/vuln/detail/CVE-2019-10432","https://github.com/jenkinsci/htmlpublisher-plugin/commit/637aad0308f8cdfb24610041fcfe815d5a1a096b","https://access.redhat.com/errata/RHSA-2019:4055","https://access.redhat.com/errata/RHSA-2019:4089","https://access.redhat.com/errata/RHSA-2019:4097","https://github.com/jenkinsci/htmlpublisher-plugin","https://github.com/jenkinsci/htmlpublisher-plugin/releases/tag/htmlpublisher-1.21","https://jenkins.io/security/advisory/2019-10-01/#SECURITY-1590","http://www.openwall.com/lists/oss-security/2019/10/01/2"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-q829-hrmc-84c8","url":"https://osv.dev/vulnerability/GHSA-q829-hrmc-84c8"}],"summary":"Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting"}