{"action":"Upgrade tiles to 2.2.0-1 or later.","affected":[{"fixed":"2.2.0-1","introduced":"0"}],"component":"tiles","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.0-1"],"id":"tcs_01M5N99ADXXED8JYPANWB3SHFG","modified_at":"2026-10-23T17:47:29.430129505Z","published_at":"2009-04-09T15:08:35.813Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-1275","https://security-tracker.debian.org/tracker/CVE-2009-1275"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-1275#Debian:14/tiles","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-1275"}],"summary":"Apache Tiles 2.1 before 2.1.2, as used in Apache Struts and other products, evaluates Expression Language (EL) expressions twice in certain circumstances, which allows remote attackers to conduct cros"}