{"action":"Upgrade opensc to 0.11.8 or later.","affected":[{"fixed":"0.11.8","introduced":"0"}],"component":"opensc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.11.8"],"id":"tcs_01M5N99VW9BMAHR1HWK7KAMSP8","modified_at":"2026-10-23T18:03:40.713440967Z","published_at":"2009-05-11T16:30:00.187Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-1603","https://security-tracker.debian.org/tracker/CVE-2009-1603"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-1603#Debian:13/opensc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-1603"}],"summary":"src/tools/pkcs11-tool.c in pkcs11-tool in OpenSC 0.11.7, when used with unspecified third-party PKCS#11 modules, generates RSA keys with incorrect public exponents, which allows attackers to read the"}