{"action":"Upgrade quagga to 1.0.20161017-r1 or later.","affected":[{"fixed":"1.0.20161017-r1","introduced":"0"}],"component":"quagga","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.4","exploited":false,"fixed_versions":["1.0.20161017-r1"],"id":"tcs_01M5N9A4AB6VT5TFPJE9R9FSKH","modified_at":"2026-06-15T18:24:26.194619817Z","published_at":"2017-10-29T20:29:00.207Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-16227","https://security.alpinelinux.org/vuln/CVE-2017-16227"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-16227#Alpine:v3.4/quagga","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-16227"}],"summary":"The aspath_put function in bgpd/bgp_aspath.c in Quagga before 1.2.2 allows remote attackers to cause a denial of service (session drop) via BGP UPDATE messages, because AS_PATH size calculation for lo"}