{"action":"Upgrade org.drools:drools-core to 4.0.7 or later.","affected":[{"fixed":"4.0.7","introduced":"0"}],"component":"org.drools:drools-core","cve_ids":["CVE-2010-3708"],"ecosystem":"Maven","epss":0.03017,"exploited":false,"fixed_versions":["4.0.7"],"ghsa_id":"GHSA-qvq6-cw53-rmwg","id":"tcs_01M5N9AATR73PND086D8J6KMVA","modified_at":"2023-11-08T03:56:57.371559Z","published_at":"2022-05-17T05:45:03Z","references":["https://osv.dev/vulnerability/GHSA-qvq6-cw53-rmwg","https://nvd.nist.gov/vuln/detail/CVE-2010-3708","https://bugzilla.redhat.com/show_bug.cgi?id=633859","https://issues.jboss.org/browse/SOA-2319","https://web.archive.org/web/20111025030056/http://securitytracker.com/id?1024813","http://www.redhat.com/support/errata/RHSA-2010-0937.html","http://www.redhat.com/support/errata/RHSA-2010-0938.html","http://www.redhat.com/support/errata/RHSA-2010-0939.html","http://www.redhat.com/support/errata/RHSA-2010-0940.html"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-qvq6-cw53-rmwg","url":"https://osv.dev/vulnerability/GHSA-qvq6-cw53-rmwg"}],"summary":"Drools Improper Input Validation vulnerability allows remote attackers to execute arbitrary code in JBoss EAP"}