{"action":"Upgrade org.apache.jspwiki:jspwiki-war to 2.12.0 or later.","affected":[{"fixed":"2.12.0","introduced":"0"}],"component":"org.apache.jspwiki:jspwiki-war","cve_ids":["CVE-2022-46907"],"ecosystem":"Maven","epss":0.01162,"exploited":false,"fixed_versions":["2.12.0"],"ghsa_id":"GHSA-qvq8-cw7f-m7m4","id":"tcs_01M5N9AB3G78SPTSXPSBZGXNMA","modified_at":"2025-02-13T19:14:04.857097Z","published_at":"2023-05-25T09:30:25Z","references":["https://osv.dev/vulnerability/GHSA-qvq8-cw7f-m7m4","https://nvd.nist.gov/vuln/detail/CVE-2022-46907","https://github.com/apache/jspwiki/commit/0b9a0149032170063f22d65e335dfd317db815ea","https://github.com/apache/jspwiki/commit/46e1ef7a595ca5cabf5ef184139910413f2024fc","https://github.com/apache/jspwiki/commit/484c6a133e397693991b7c9a9b62ef3ca48ce707","https://github.com/apache/jspwiki/commit/75019d337f1d0033b1f65428e75f43baeffd99dd","https://github.com/apache/jspwiki/commit/82be08904a6d8bd22fa2d4e5a7e85f43408724d3","https://github.com/apache/jspwiki/commit/9d6dbf911d52d724297e4e46c4b80649fb028ff9","https://github.com/apache/jspwiki/commit/df20770f251a8d7431047e556b144ef24ee6a3a7","https://github.com/apache/jspwiki","https://github.com/apache/jspwiki/blob/37bf55373ed5a739a388a720163cf51d1104537f/ChangeLog.md?plain=1#L112","https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-46907","https://lists.apache.org/thread/1m0mkq2nttx8tn94m11mytn4f0tv1504","http://www.openwall.com/lists/oss-security/2023/05/25/1"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-qvq8-cw7f-m7m4#Maven/org.apache.jspwiki:jspwiki-war","url":"https://osv.dev/vulnerability/GHSA-qvq8-cw7f-m7m4"}],"summary":"Apache JSPWiki vulnerable to cross-site scripting on several plugins"}