{"action":"Upgrade strongswan to 4.2.14-1.2 or later.","affected":[{"fixed":"4.2.14-1.2","introduced":"0"}],"component":"strongswan","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.2.14-1.2"],"id":"tcs_01M5N9AD7610DVDA98MN1234B0","modified_at":"2026-10-23T17:47:39.324026941Z","published_at":"2009-06-25T02:00:00.297Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-2185","https://security-tracker.debian.org/tracker/CVE-2009-2185"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-2185#Debian:14/strongswan","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-2185"}],"summary":"The ASN.1 parser (pluto/asn1.c, libstrongswan/asn1/asn1.c, libstrongswan/asn1/asn1_parser.c) in (a) strongSwan 2.8 before 2.8.10, 4.2 before 4.2.16, and 4.3 before 4.3.2; and (b) openSwan 2.6 before 2"}