{"action":"Upgrade mapserver to 5.4.2-1 or later.","affected":[{"fixed":"5.4.2-1","introduced":"0"}],"component":"mapserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.4.2-1"],"id":"tcs_01M5N9ADSATE01T6N3MN6T7SHC","modified_at":"2026-10-23T17:47:26.021941195Z","published_at":"2009-10-23T18:30:00.297Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-2281","https://security-tracker.debian.org/tracker/CVE-2009-2281"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-2281","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-2281"}],"summary":"Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1)"}