{"action":"Upgrade org.apache.cassandra:cassandra-all to 5.0.7 or later.","affected":[{"fixed":"5.0.7","introduced":"5.0-alpha1"}],"component":"org.apache.cassandra:cassandra-all","cve_ids":["CVE-2026-27314"],"ecosystem":"Maven","epss":0.00263,"exploited":false,"fixed_versions":["5.0.7"],"ghsa_id":"GHSA-qxpc-96fq-wwmg","id":"tcs_01M5N9AHPQTZ16JJVJHBGPWSH6","modified_at":"2026-04-08T19:41:25.037036Z","published_at":"2026-04-07T18:31:37Z","references":["https://osv.dev/vulnerability/GHSA-qxpc-96fq-wwmg","https://nvd.nist.gov/vuln/detail/CVE-2026-27314","https://github.com/apache/cassandra/commit/b584a435970e5125e1def5148d943c39569dc7af","https://github.com/apache/cassandra","https://github.com/apache/cassandra/releases/tag/cassandra-5.0.7","https://lists.apache.org/thread/zrng82ddy4rpsmfyk582v6hqxcqrbz7f","http://www.openwall.com/lists/oss-security/2026/04/07/7"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-qxpc-96fq-wwmg","url":"https://osv.dev/vulnerability/GHSA-qxpc-96fq-wwmg"}],"summary":"Apache Cassandra is vulnerable to privilege escalation in an mTLS environment using MutualTlsAuthenticator"}