{"action":"Upgrade openssl to 0.9.8k-4 or later.","affected":[{"fixed":"0.9.8k-4","introduced":"0"}],"component":"openssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.8k-4"],"id":"tcs_01M5N9AMY26VFA7R65DC900M83","modified_at":"2026-10-23T17:47:33.673927227Z","published_at":"2009-07-30T19:30:00.343Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-2409","https://security-tracker.debian.org/tracker/CVE-2009-2409"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-2409#Debian:12/openssl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-2409"}],"summary":"The Network Security Services (NSS) library before 3.12.3, as used in Firefox; GnuTLS before 2.6.4 and 2.7.4; OpenSSL 0.9.8 through 0.9.8k; and other products support MD2 with X.509 certificates, whic"}