{"action":"Upgrade org.apache.james:james-server to 3.6.1 or later.","affected":[{"fixed":"3.6.1","introduced":"3.1.0"}],"component":"org.apache.james:james-server","cve_ids":["CVE-2021-40110"],"ecosystem":"Maven","epss":0.02954,"exploited":false,"fixed_versions":["3.6.1"],"ghsa_id":"GHSA-r58x-wjg8-63m9","id":"tcs_01M5N9AZVGT4N68Z034VDB8615","modified_at":"2026-09-10T03:49:11.106080514Z","published_at":"2022-01-08T00:40:30Z","references":["https://osv.dev/vulnerability/GHSA-r58x-wjg8-63m9","https://nvd.nist.gov/vuln/detail/CVE-2021-40110","https://www.openwall.com/lists/oss-security/2022/01/04/2","http://www.openwall.com/lists/oss-security/2022/01/04/2"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-r58x-wjg8-63m9","url":"https://osv.dev/vulnerability/GHSA-r58x-wjg8-63m9"}],"summary":"Denial of Service in Apache James"}