{"action":"Upgrade cups to 1.4.2-1 or later.","affected":[{"fixed":"1.4.2-1","introduced":"0"}],"component":"cups","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.4.2-1"],"id":"tcs_01M5N9B7VTMGXDS5MR2EMBC6TA","modified_at":"2026-10-23T17:47:49.920423260Z","published_at":"2009-11-10T19:30:01.217Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-2820","https://security-tracker.debian.org/tracker/CVE-2009-2820"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-2820","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-2820"}],"summary":"The web interface in CUPS before 1.4.2, as used on Apple Mac OS X before 10.6.2 and other platforms, does not properly handle (1) HTTP headers and (2) HTML templates, which allows remote attackers to"}