{"action":"Upgrade devscripts to 2.10.54 or later.","affected":[{"fixed":"2.10.54","introduced":"0"}],"component":"devscripts","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.10.54"],"id":"tcs_01M5N9BFDT0Q9XG3C4P4Z10CS6","modified_at":"2026-10-23T17:47:49.166424677Z","published_at":"2009-09-04T20:30:00.233Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-2946","https://security-tracker.debian.org/tracker/CVE-2009-2946"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-2946#Debian:13/devscripts","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-2946"}],"summary":"Eval injection vulnerability in scripts/uscan.pl before Rev 1984 in devscripts allows remote attackers to execute arbitrary Perl code via crafted pathnames on distribution servers for upstream source"}