{"action":"Upgrade org.apache.nifi:nifi-single-user-utils to 1.16 or later.","affected":[{"fixed":"1.16","introduced":"0"}],"component":"org.apache.nifi:nifi-single-user-utils","cve_ids":["CVE-2022-26850"],"ecosystem":"Maven","epss":0.01493,"exploited":false,"fixed_versions":["1.16"],"ghsa_id":"GHSA-rvp4-r3g6-8hxq","id":"tcs_01M5N9CNCGWSP09YQ5J9MDFBDP","modified_at":"2025-09-15T07:41:59.149471Z","published_at":"2022-06-20T22:33:41Z","references":["https://osv.dev/vulnerability/GHSA-rvp4-r3g6-8hxq","https://github.com/JLLeitschuh/security-research/security/advisories/GHSA-rvp4-r3g6-8hxq","https://nvd.nist.gov/vuln/detail/CVE-2022-26850","https://github.com/apache/nifi/commit/859d5fe","https://github.com/apache/nifi/commit/859d5fe8cfe05ad24600b021f0ebf15753a8105c","https://nifi.apache.org/security.html#CVE-2022-26850","http://www.openwall.com/lists/oss-security/2022/04/06/2"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-rvp4-r3g6-8hxq","url":"https://osv.dev/vulnerability/GHSA-rvp4-r3g6-8hxq"}],"summary":"Insufficiently Protected Credentials via Insecure Temporary File in org.apache.nifi:nifi-single-user-utils"}