{"action":"Upgrade xpdf to 3.02-2 or later.","affected":[{"fixed":"3.02-2","introduced":"0"}],"component":"xpdf","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.02-2"],"id":"tcs_01M5N9CXRSBV70H9GK7834ANGE","modified_at":"2026-10-23T17:47:46.776405585Z","published_at":"2009-10-21T17:30:00.453Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-3609","https://security-tracker.debian.org/tracker/CVE-2009-3609"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-3609#Debian:13/xpdf","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-3609"}],"summary":"Integer overflow in the ImageStream::ImageStream function in Stream.cc in Xpdf before 3.02pl4 and Poppler before 0.12.1, as used in GPdf, kdegraphics KPDF, and CUPS pdftops, allows remote attackers to"}