{"action":"Upgrade qemu to 0.11.0-1 or later.","affected":[{"fixed":"0.11.0-1","introduced":"0"}],"component":"qemu","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.11.0-1"],"id":"tcs_01M5N9CZAQ3SQ617YZM8EWZP38","modified_at":"2026-10-23T18:02:38.647338988Z","published_at":"2009-10-23T18:30:00.390Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-3616","https://security-tracker.debian.org/tracker/CVE-2009-3616"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-3616","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-3616"}],"summary":"Multiple use-after-free vulnerabilities in vnc.c in the VNC server in QEMU 0.10.6 and earlier might allow guest OS users to execute arbitrary code on the host OS by establishing a connection from a VN"}