{"action":"Upgrade it.geosolutions.jaiext.jiffle:jt-jiffle to 1.1.22 or later.","affected":[{"fixed":"1.1.22","introduced":"0"}],"component":"it.geosolutions.jaiext.jiffle:jt-jiffle","cve_ids":["CVE-2022-24816"],"ecosystem":"Maven","epss":0.99911,"exploited":true,"fixed_versions":["1.1.22"],"ghsa_id":"GHSA-v92f-jx6p-73rx","id":"tcs_01M5N9DPH85P98CEGNP9D9DVDQ","modified_at":"2025-10-22T19:17:43Z","published_at":"2023-09-19T20:35:16Z","references":["https://osv.dev/vulnerability/GHSA-v92f-jx6p-73rx","https://github.com/geosolutions-it/jai-ext/security/advisories/GHSA-v92f-jx6p-73rx","https://nvd.nist.gov/vuln/detail/CVE-2022-24816","https://github.com/geosolutions-it/jai-ext/commit/cb1d6565d38954676b0a366da4f965fef38da1cb","https://github.com/geosolutions-it/jai-ext","https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-24816"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-v92f-jx6p-73rx","url":"https://osv.dev/vulnerability/GHSA-v92f-jx6p-73rx"},{"source":"kev","source_id":"CVE-2022-24816","url":"https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json"}],"summary":"Improper Control of Generation of Code ('Code Injection') in jai-ext"}