{"action":"Upgrade gimp to 2.6.7-1.1 or later.","affected":[{"fixed":"2.6.7-1.1","introduced":"0"}],"component":"gimp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.6.7-1.1"],"id":"tcs_01M5N9DVVSPYP14990FBMKNE30","modified_at":"2026-10-23T17:47:24.373912444Z","published_at":"2009-11-19T00:30:00.233Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-3909","https://security-tracker.debian.org/tracker/CVE-2009-3909"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-3909#Debian:13/gimp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-3909"}],"summary":"Integer overflow in the read_channel_data function in plug-ins/file-psd/psd-load.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a crafted PSD file that triggers a heap-base"}