{"action":"Upgrade libsoup to 2.56.1-r0 or later.","affected":[{"fixed":"2.56.1-r0","introduced":"0"}],"component":"libsoup","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.5","exploited":false,"fixed_versions":["2.56.1-r0"],"id":"tcs_01M5N9DW2EFCVBF30JC3E3PMKG","modified_at":"2026-06-15T18:24:34.389277498Z","published_at":"2018-04-24T19:29:02.783Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-2885","https://security.alpinelinux.org/vuln/CVE-2017-2885"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-2885#Alpine:v3.5/libsoup","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-2885"}],"summary":"An exploitable stack based buffer overflow vulnerability exists in the GNOME libsoup 2.58. A specially crafted HTTP request can cause a stack overflow resulting in remote code execution. An attacker c"}