{"action":"Upgrade pdns-recursor to 3.1.7.2-1 or later.","affected":[{"fixed":"3.1.7.2-1","introduced":"0"}],"component":"pdns-recursor","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.1.7.2-1"],"id":"tcs_01M5N9DZW0NWP6Z644F948BKJC","modified_at":"2026-10-23T17:47:42.045471178Z","published_at":"2010-01-08T17:30:02.207Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-4009","https://security-tracker.debian.org/tracker/CVE-2009-4009"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-4009","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-4009"}],"summary":"Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via crafted packets."}