{"action":"Upgrade libthai to 0.1.13-1 or later.","affected":[{"fixed":"0.1.13-1","introduced":"0"}],"component":"libthai","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.1.13-1"],"id":"tcs_01M5N9E0VH08VEJK4STYG0TFR2","modified_at":"2026-10-23T17:47:21.645854341Z","published_at":"2010-01-19T16:30:00.790Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-4012","https://security-tracker.debian.org/tracker/CVE-2009-4012"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-4012#Debian:13/libthai","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-4012"}],"summary":"Multiple integer overflows in LibThai before 0.1.13 might allow context-dependent attackers to execute arbitrary code via long strings that trigger heap-based buffer overflows, related to (1) thbrk/th"}