{"action":"Upgrade org.apache.kafka:kafka-clients to 3.9.1 or later.","affected":[{"fixed":"3.9.1","introduced":"3.1.0"}],"component":"org.apache.kafka:kafka-clients","cve_ids":["CVE-2025-27817"],"ecosystem":"Maven","epss":0.68776,"exploited":false,"fixed_versions":["3.9.1"],"ghsa_id":"GHSA-vgq5-3255-v292","id":"tcs_01M5N9E2BP52J8VRYX7B9NN6AE","modified_at":"2026-09-10T03:50:25.468399734Z","published_at":"2025-06-10T09:30:31Z","references":["https://osv.dev/vulnerability/GHSA-vgq5-3255-v292","https://nvd.nist.gov/vuln/detail/CVE-2025-27817","https://github.com/apache/kafka","https://kafka.apache.org/cve-list","http://www.openwall.com/lists/oss-security/2025/06/09/1"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-vgq5-3255-v292","url":"https://osv.dev/vulnerability/GHSA-vgq5-3255-v292"}],"summary":"Apache Kafka Client Arbitrary File Read and Server Side Request Forgery Vulnerability"}