{"action":"Upgrade rails to 2.2.3-2 or later.","affected":[{"fixed":"2.2.3-2","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.2.3-2"],"id":"tcs_01M5N9EB09DMAJNR9HB8HEY2MD","modified_at":"2026-10-23T17:47:35.946143109Z","published_at":"2009-12-07T17:30:00.217Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-4214","https://security-tracker.debian.org/tracker/CVE-2009-4214"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-4214#Debian:13/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-4214"}],"summary":"Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors in"}