{"action":"Upgrade org.apache.shenyu:shenyu-admin to 2.4.1 or later.","affected":[{"fixed":"2.4.1","introduced":"2.3.0"}],"component":"org.apache.shenyu:shenyu-admin","cve_ids":["CVE-2021-37580"],"ecosystem":"Maven","epss":0.4212,"exploited":false,"fixed_versions":["2.4.1"],"ghsa_id":"GHSA-vpfp-5gwq-g533","id":"tcs_01M5N9EGHKMC6V96P0MBTXDA97","modified_at":"2024-02-16T08:24:45.527587Z","published_at":"2021-11-17T23:15:30Z","references":["https://osv.dev/vulnerability/GHSA-vpfp-5gwq-g533","https://nvd.nist.gov/vuln/detail/CVE-2021-37580","https://github.com/apache/shenyu/commit/f78adb26926ba53b4ec5c21f2cf7e931461d601d","https://github.com/apache/shenyu","https://github.com/apache/shenyu/releases/tag/v2.4.1","https://lists.apache.org/thread/o15j25qwtpcw62k48xw1tnv48skh3zgb","http://www.openwall.com/lists/oss-security/2021/11/16/1"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-vpfp-5gwq-g533","url":"https://osv.dev/vulnerability/GHSA-vpfp-5gwq-g533"}],"summary":"Improper Authentication in Apache ShenYu Admin"}