{"action":"Upgrade org.jenkins-ci.plugins:git-server to 99.101.v720e86326c09 or later.","affected":[{"fixed":"99.101.v720e86326c09","introduced":"0"}],"component":"org.jenkins-ci.plugins:git-server","cve_ids":["CVE-2024-23899"],"ecosystem":"Maven","epss":0.01262,"exploited":false,"fixed_versions":["99.101.v720e86326c09"],"ghsa_id":"GHSA-vph5-2q33-7r9h","id":"tcs_01M5N9EGSWFC5E9Z7DKX580CTE","modified_at":"2025-06-04T23:04:58.532276Z","published_at":"2024-01-24T18:31:02Z","references":["https://osv.dev/vulnerability/GHSA-vph5-2q33-7r9h","https://nvd.nist.gov/vuln/detail/CVE-2024-23899","https://github.com/jenkinsci/git-server-plugin/commit/068ac7cc2574882ef9f5a486e001228a71d881ad","https://github.com/jenkinsci/git-server-plugin","https://www.jenkins.io/security/advisory/2024-01-24/#SECURITY-3319","http://www.openwall.com/lists/oss-security/2024/01/24/6"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-vph5-2q33-7r9h","url":"https://osv.dev/vulnerability/GHSA-vph5-2q33-7r9h"}],"summary":"Arbitrary file read vulnerability in Git server Plugin can lead to RCE"}