{"action":"Upgrade mediawiki to 1:1.15.0-1.1 or later.","affected":[{"fixed":"1:1.15.0-1.1","introduced":"0"}],"component":"mediawiki","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1:1.15.0-1.1"],"id":"tcs_01M5N9EPZ2MN6SH3K1ZNAN0MT5","modified_at":"2026-10-23T17:47:36.016903590Z","published_at":"2010-01-07T18:30:00.917Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-4589","https://security-tracker.debian.org/tracker/CVE-2009-4589"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-4589#Debian:13/mediawiki","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-4589"}],"summary":"Cross-site scripting (XSS) vulnerability in the Special:Block implementation in the getContribsLink function in SpecialBlockip.php in MediaWiki 1.14.0 and 1.15.0 allows remote attackers to inject arbi"}