{"action":"Upgrade org.apache.ranger:ranger to 2.5.0 or later.","affected":[{"fixed":"2.5.0","introduced":"0"}],"component":"org.apache.ranger:ranger","cve_ids":["CVE-2024-45478"],"ecosystem":"Maven","epss":0.00607,"exploited":false,"fixed_versions":["2.5.0"],"ghsa_id":"GHSA-vrx2-mgr9-v67h","id":"tcs_01M5N9ESQKV8PEXQETVJV13TBK","modified_at":"2025-06-10T21:27:15.416889Z","published_at":"2025-01-22T00:33:35Z","references":["https://osv.dev/vulnerability/GHSA-vrx2-mgr9-v67h","https://nvd.nist.gov/vuln/detail/CVE-2024-45478","https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger","https://github.com/apache/ranger","http://www.openwall.com/lists/oss-security/2025/01/21/3"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-vrx2-mgr9-v67h","url":"https://osv.dev/vulnerability/GHSA-vrx2-mgr9-v67h"}],"summary":"Apache Ranger has Stored Cross-site Scripting vulnerability in Edit Service Page"}