{"action":"Upgrade org.apache.knox:gateway-service-knoxsso to 1.6.1 or later.","affected":[{"fixed":"1.6.1","introduced":"0"}],"component":"org.apache.knox:gateway-service-knoxsso","cve_ids":["CVE-2021-42357"],"ecosystem":"Maven","epss":0.02579,"exploited":false,"fixed_versions":["1.6.1"],"ghsa_id":"GHSA-vv38-4xcj-q4rw","id":"tcs_01M5N9ESW1ENQCAPYWZR49Y6QA","modified_at":"2023-11-08T04:07:05.836680Z","published_at":"2022-01-21T23:52:00Z","references":["https://osv.dev/vulnerability/GHSA-vv38-4xcj-q4rw","https://nvd.nist.gov/vuln/detail/CVE-2021-42357","https://lists.apache.org/thread/b7v5dkpyqb51nw0lvz4cybhgrfhk1g7j","http://www.openwall.com/lists/oss-security/2022/01/17/2"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-vv38-4xcj-q4rw","url":"https://osv.dev/vulnerability/GHSA-vv38-4xcj-q4rw"}],"summary":"Cross-site Scripting in Apache Knox SSO"}