{"action":"Upgrade samhain to 2.5.4-1 or later.","affected":[{"fixed":"2.5.4-1","introduced":"0"}],"component":"samhain","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.5.4-1"],"id":"tcs_01M5N9EXRTA9MZ8R95R8H2D83B","modified_at":"2026-10-23T17:47:33.584156919Z","published_at":"2010-04-23T14:30:01.103Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-4810","https://security-tracker.debian.org/tracker/CVE-2009-4810"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-4810#Debian:14/samhain","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-4810"}],"summary":"The Secure Remote Password (SRP) implementation in Samhain before 2.5.4 does not check for a certain zero value where required by the protocol, which allows remote attackers to bypass authentication v"}