{"action":"Upgrade org.apache.struts:struts2-core to 2.3.20 or later.","affected":[{"fixed":"2.3.20","introduced":"0"}],"component":"org.apache.struts:struts2-core","cve_ids":["CVE-2015-5169"],"ecosystem":"Maven","epss":0.07533,"exploited":false,"fixed_versions":["2.3.20"],"ghsa_id":"GHSA-vwhv-j36g-5rm8","id":"tcs_01M5N9EYD68ZFRF1CER4V7C20M","modified_at":"2024-02-18T05:32:35.719242Z","published_at":"2022-05-14T01:57:02Z","references":["https://osv.dev/vulnerability/GHSA-vwhv-j36g-5rm8","https://nvd.nist.gov/vuln/detail/CVE-2015-5169","https://bugzilla.redhat.com/show_bug.cgi?id=1260087","https://github.com/apache/struts","https://security.netapp.com/advisory/ntap-20180629-0003","https://struts.apache.org/docs/s2-025.html","http://jvn.jp/en/jp/JVN95989300/index.html","http://jvndb.jvn.jp/en/contents/2015/JVNDB-2015-000125.html"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-vwhv-j36g-5rm8","url":"https://osv.dev/vulnerability/GHSA-vwhv-j36g-5rm8"}],"summary":"Cross-site Scripting in Apache Struts"}