{"action":"Upgrade glibc to 2.28-1 or later.","affected":[{"fixed":"2.28-1","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.28-1"],"id":"tcs_01M5N9FCJ80E487AP06YSCHC88","modified_at":"2026-10-23T18:00:09.661735281Z","published_at":"2019-02-26T02:29:00.277Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2009-5155","https://security-tracker.debian.org/tracker/CVE-2009-5155"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2009-5155#Debian:14/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2009-5155"}],"summary":"In the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application e"}