{"action":"Upgrade puppet to 0.25.4-2 or later.","affected":[{"fixed":"0.25.4-2","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["0.25.4-2"],"id":"tcs_01M5N9FHE9TSPWX7XKTS2H4TWB","modified_at":"2026-08-15T06:47:33.858990114Z","published_at":"2010-03-03T19:30:00.447Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-0156","https://security-tracker.debian.org/tracker/CVE-2010-0156"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-0156","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-0156"}],"summary":"Puppet 0.24.x before 0.24.9 and 0.25.x before 0.25.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/daemonout, (2) /tmp/puppetdoc.txt, (3) /tmp/puppetdoc.tex, or"}