{"action":"Upgrade org.apache.geode:geode-web-api to 1.15.2 or later.","affected":[{"fixed":"1.15.2","introduced":"1.1.0"}],"component":"org.apache.geode:geode-web-api","cve_ids":["CVE-2024-44088"],"ecosystem":"Maven","epss":0.00689,"exploited":false,"fixed_versions":["1.15.2"],"ghsa_id":"GHSA-w595-4975-gm3h","id":"tcs_01M5N9FMCSD1JEHYM4QWR6F7BC","modified_at":"2025-11-05T20:53:08.185359Z","published_at":"2025-10-14T15:31:27Z","references":["https://osv.dev/vulnerability/GHSA-w595-4975-gm3h","https://nvd.nist.gov/vuln/detail/CVE-2024-44088","https://github.com/apache/geode","https://lists.apache.org/thread/161r34nokmcc0w74mnf04lskgb8g1d3g","http://www.openwall.com/lists/oss-security/2025/10/14/5"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-w595-4975-gm3h","url":"https://osv.dev/vulnerability/GHSA-w595-4975-gm3h"}],"summary":"Apache Geode web-api is vulnerable to Cross-site Scripting"}