{"action":"Upgrade org.apache.polaris:polaris-runtime-service to 1.4.1 or later.","affected":[{"fixed":"1.4.1","introduced":"0.9.0"}],"component":"org.apache.polaris:polaris-runtime-service","cve_ids":["CVE-2026-42812"],"ecosystem":"Maven","epss":0.00365,"exploited":false,"fixed_versions":["1.4.1"],"ghsa_id":"GHSA-w76p-3cgp-qfcm","id":"tcs_01M5N9FT5WWTFXF1W9FXDW9T8Q","modified_at":"2026-08-31T23:00:09.804903645Z","published_at":"2026-05-04T18:30:31Z","references":["https://osv.dev/vulnerability/GHSA-w76p-3cgp-qfcm","https://nvd.nist.gov/vuln/detail/CVE-2026-42812","https://github.com/apache/polaris/commit/1cdac7b78c0aa6cc6cad4da10a442ae262d1aae3","https://github.com/apache/polaris/commit/d6bbcc386e61d08ba5df1f820d0724816d84427b","https://github.com/apache/polaris","https://lists.apache.org/thread/wxd2wj3p0smvrk84msv317wg5tp3jtw9","http://www.openwall.com/lists/oss-security/2026/05/02/13"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"GHSA-w76p-3cgp-qfcm","url":"https://osv.dev/vulnerability/GHSA-w76p-3cgp-qfcm"}],"summary":"Apache Polaris has an Improper Input Validation issue"}