{"action":"Upgrade org.keycloak:keycloak-parent to 19.0.2 or later.","affected":[{"fixed":"19.0.2","introduced":"0"}],"component":"org.keycloak:keycloak-parent","cve_ids":["CVE-2022-2256"],"ecosystem":"Maven","epss":0.00696,"exploited":false,"fixed_versions":["19.0.2"],"ghsa_id":"GHSA-w9mf-83w3-fv49","id":"tcs_01M5N9G16HPTBGCE3AN4QF3GCJ","modified_at":"2026-05-04T08:46:05.321219676Z","published_at":"2022-09-23T16:32:51Z","references":["https://osv.dev/vulnerability/GHSA-w9mf-83w3-fv49","https://github.com/keycloak/keycloak/security/advisories/GHSA-w9mf-83w3-fv49","https://nvd.nist.gov/vuln/detail/CVE-2022-2256","https://github.com/keycloak/keycloak/commit/8e705a65ab2aa2b079374ec859ee7a75fad5a7d9","https://bugzilla.redhat.com/show_bug.cgi?id=2101942","https://github.com/keycloak/keycloak"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-w9mf-83w3-fv49","url":"https://osv.dev/vulnerability/GHSA-w9mf-83w3-fv49"}],"summary":"Keycloak vulnerable to Stored Cross site Scripting (XSS) when loading default roles"}