{"action":"Upgrade org.apache.kylin:kylin-server-base to 4.0.3 or later.","affected":[{"fixed":"4.0.3","introduced":"2.0.0"}],"component":"org.apache.kylin:kylin-server-base","cve_ids":["CVE-2022-44621"],"ecosystem":"Maven","epss":0.03052,"exploited":false,"fixed_versions":["4.0.3"],"ghsa_id":"GHSA-w9rv-xmf7-x3gh","id":"tcs_01M5N9G1T5DAG6G8QW9GDSCP65","modified_at":"2025-04-11T23:41:17.098877Z","published_at":"2022-12-30T12:30:25Z","references":["https://osv.dev/vulnerability/GHSA-w9rv-xmf7-x3gh","https://nvd.nist.gov/vuln/detail/CVE-2022-44621","https://github.com/apache/kylin/pull/2011","https://github.com/apache/kylin/pull/2011/commits/418a63c61379d429312972fc94b87994e06b664f","https://github.com/apache/kylin/commit/fd2977e21c51f1afed668f2d9713cf562f2dc42d","https://github.com/apache/kylin","https://lists.apache.org/thread/7ctchj24dofgsj9g1rg1245cms9myb34"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-w9rv-xmf7-x3gh","url":"https://osv.dev/vulnerability/GHSA-w9rv-xmf7-x3gh"}],"summary":"Apache Kylin vulnerable to Command injection by Diagnosis Controller"}